cara setting DHCP Router Cisco

Cara Setting DHCP Router Cisco (Server dan Client)

Kamu baru belajar cisco dan bingung bagaimana cara konfigurasi DHCP pada Router Cisco? Tenang, pada artikel ini, kakak iyainaja akan membahas mengenai cara setting DHCP Router Cisco.

Apa itu DHCP

Sebelum membahas bagaimana cara konfigurasinya, ada baiknya untuk kamu tahu dulu “apa itu DHCP”. DHCP (dynamic host configuration protocol) merupakan protokol jaringan, yang berfungsi untuk memberikan ip address secara dinamis. Salah satu fungsi DHCP, yaitu untuk mempermudah dalam setting ip, baik itu pada komputer client ataupun pada perangkat jaringan lainnya.

DHCP dibagi menjadi tiga:

  • Server, memberikan ip address ke Client
  • Client, menerima ip address dari Server
  • Relay, meneruskan packet DHCP antara Client dan Server.

Itu tadi sepintas tentang pengertian dhcp. Sekarang saatnya bagimu, untuk tahu lebih tentang cara settingnya!

Cara Setting DHCP Router Cisco

Pada artikel ini, kakak paparkan dua konfigurasi DHCP pada perangkat cisco. Pertama Router sebagai DHCP Server, dan yang kedua Router sebagai DHCP Client. Adapun topologi yang perlu kamu perhatikan sebagai berikut.

topologi sederhana cara setting DHCP Router Cisco
topologi sederhana cara setting DHCP Router Cisco

Seperti yang terlihat pada gambar diatas. Terdapat dua buah router, satu buah switch, satu buah pc biasa, dan pc server. Silakan hubungkan semua perangkat tersebut menggunakan kabel.

Untuk kabel yang digunakan bebas. Kamu dapat menggunakan kabel cross / straight. Namun perlu kamu ingat, bahwa tidak semua perangkat cisco sudah mendukung auto mdix / auto sensing. Ada baiknya kamu tetap menggunakan aturan baku.

Cara Setting DHCP Server Cisco

Berikut langkah langkah setting dhcp server pada perangkat cisco. Silakan baca dan ikuti langkah langkah berikut, dengan cermat.

1. Pastikan router sudah tersambung

Pertama, pastikan router dan perangkat lainnya tersambung menggunakan media transmisi yang benar.

2. Remote perangkat router

Selanjutnya, silakan lakukan remote perangkat router.Jika menggunakan aplikasi cisco packet tracer, silakan langsung buka tab cli / terminal. Namun jika menggunakan perangkat langsung, silakan remote menggunakan putty, berikut langkah langkahnya.

  • Buka aplikasi putty.
  • Silakan isi “serial line” yang sesuai dengan komputer atau laptopmu.
  • Silakan isi “speed” dengan baud rate yang sesuai dengan router yang kamu setting.
  • Pilih connection type “serial”.
  • Klik open.
  • Setelah berhasil teremote, apabila muncul tulisan ” enter the initial configuration dialog? [yes/no]” silakan ketikan “no”.
  • Kemudian ketikan “enable” dan dilanjutkan mengetikan “configure terminal”.

3. Beri ip pada interface

Langkah selanjutnya yaitu menambahkan ip address, pada interface. Sebagai contoh pada artikel ini menambahkan ip pada interface GigabitEthernet 0/0. Silakan simak perintah berikut.

Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.1.1 255.255.255.0

Penjelasan
Baris1:masuk ke interface GigabitEthernet 0/0
Baris2: menghidupkan interface GigabitEthernet 0/0
Baris3: menambahkan ip ke interface GigabitEthernet 0/0

4. Konfigurasi DHCP server

Setelah menambahkan ip address pada interface, langkah selanjutnya yaitu mengkonfigurasi dhcp server. Silakan simak dan ikuti command / perintah dibawah.

Router(config)#ip dhcp pool LAB
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 192.168.1.1
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(config)#ip dhcp excluded-address 192.168.1.1
Router(config)#ip dhcp excluded-address 192.168.1.2 192.168.1.10

Penjelasan
Baris1: ip dhcp pool [NAMA DHCP], dapat kamu ganti menjadi nama yang lain.
Baris2: ip default router, ip router yang akan menjadi default gateway.
Baris3: ip dns server yang digunakan.
Baris4: isi alamat network address dan subnetmasknya
Baris5: satu alamat ip tersebut tidak akan dibroadcastkan
Baris6: rentang alamat ip tersebut tidak akan dibagikan.

Catatan
Baris 1-4:wajib ada/wajib dilakukan.
Baris 5&6: optional / tidak wajib dilakukan. Silakan dilakukan untuk mengecualikan ip yang tidak ingin kamu bagikan. Sebagai contoh jika nantinya terdapat lima buah server, dan lima buah access point. Maka silakan masukkan alamat server /access point tersebut, kedalam exluded address.

5. Verifikasi

Langkah terakhir yaitu, mengetest guna verifikasi apakah sudah mendapatkan alamat ip atau belum. Pastikan perangkat mendapatkan ip, sesuai dengan yang sudah disetting. Apabila perangkat yang menerima ip sebuah router, silakan langsung simak kebagian cara setting dhcp client cisco. Namun jika perangkat seperti komputer, silakan simak berikut ini.

Komputer Real

  • Buka windows run, dengan menekan tombol “windows + r”.
  • Kemudian ketikan “cmd” lalu tekan enter.
  • Pada command prompt silakan ketikan “ipconfig”.
  • Pastikan pada bagian ethernet, mendapatkan alamat ip, sesuai dengan yang kamu setting.

Komputer Packet Tracer

  • Klik pc
  • Buka tab desktop, kemudian pilih “ip configuration”
  • Kemudian silakan “pilih DHCP”, dan tunggu beberapa saat hingga mendapatkan ip dari DHCP server.
  • Pastikan pc mendapatkan alamat ip sesuai dengan yang kamu setting.

Kamu juga dapat mengecek ip dhcp yang sudah terkoneksi dengan server. Silakan ketikan beberapa command berikut, untuk melihat ip client yang terkoneksi.

Router#show ip dhcp binding

Dengan perintah “show ip dhcp binding”, akan muncul infomasi seperti ip address dan client id. Jika kamu ingin menampilkan jumlah client yang terkoneksi, kamu dapat mengetikan perintah berikut.

pengecekan dhcp pada router cisco
pengecekan dhcp pada router cisco
Router#show ip dhcp pool

Silakan perhatikan pada bagian leased address. Angka pada bagian leased address, menunjukan jumlah ip perangkat yang menggunakan ip dhcp.

Cara Setting DHCP Client Cisco

Seperti yang kamu ketahui sebelumnya, bahwa perangkat router juga dapat sebagai DHCP Client. Perangkat router dapat menerima ip dinamis. Berikut langkah langkah cara setting dhcp client di router cisco.

1. Pastikan perangkat sudah tersambung

Pertama, pastikan perangkat sudah tersambung dengan media transmisi yang benar.

2. Remote perangkat

Selanjutnya, silakan remote perangkat router.

3. Konfigurasi DHCP Client

Setelah perangkat router berhasil kamu remote, langkah berikutnya yaitu mengkonfigurasi dhcp client. Silakan ikuti beberapa perintah berikut.

Router(config)#int g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp

Selang beberapa detik, router pun akan mendapatkan ip dari router yang menjadi dhcp server. Untuk mengetahui mendapatkan ip berapa. Kamu dapat mengetikan perintah “show ip interface brief”.

FAQ

Q: Apa itu ip DHCP excluded Address?
A: DHCP exluded adalah alamat ip yang tidak dibagikan. Sebagai contoh:

  • Dalam suatu jaringan dengan alamat ip 192.168.1.0/24
  • Terdapat lima buah access point, satu buah server, dan 20 pc.
  • Maka silakan kecualikan alamat ip access point, dan server tersebut.
  • Tujuannya agar access point dan server menggunakan ip static, sehingga lebih memudahkan dalam memanejemen perangkat.

Q: Ka, apakah panduan ini dapat digunakan pada perangkat asli atau menggunakan simulator cisco packet tracer.
A: Panduan ini, bisa digunakan untuk keduanya. Untuk perangkat asli dan cisco packet tracer.

Q: Ka, aku sudah ikuti panduan diatas, namun perangkat jaringan lain belum mendapatkan ip dhcp. Kira kira penyebabnya karena apa?
A: Silakan check beberapa hal berikut:

  • Konfigurasi dhcp server sudah benar atau belum?
  • Check ip pada interface router
  • Cek juga pada kabel yang kamu gunakan.
  • Check interface dalam keadaan menyala atau mati?

Q: Ka, apakah satu router bisa sebagai DHCP Server sekaligus Client?
A: Bisa, satu router bisa menjadi Server dan menjadi Client.

Kesimpulan

Jadi begitulah cara setting DHCP router cisco. Router dapat digunakan sebagai DHCP server maupun sebagai DHCP Client. Semoga artikel ini membantumu dalam memahami DHCP dan cara konfigurasi pada router cisco. Terima kasih telah membaca artikel di iyainaja.my.id. Sampai jumpa pada artikel berikutnya.

Referensi

  • Cisco. “Configuring the Cisco IOS DHCP Server.” Cisco.com https://www.cisco.com/en/US/docs/ios/12_4t/ip_addr/configuration/guide/htdhcpsv.html (diakses pada 16 Juni 2022)

Leave a Reply

Your email address will not be published.